Resolved
Source Instagram: Incompatible metrics (engagement, impressions, video_views) with reel media

Started
September 08, 2022 at 7:05 AM
Status
Resolved after about 9 hours

Impact

Operational
Affected
API Connector
  • Resolved
    September 08, 2022 at 4:14 PM

    We just resolved the issue! Thank you for your patience as we worked towards a resolution.

  • Monitoring
    September 08, 2022 at 3:48 PM

    We implemented a fix and currently monitoring the result.

  • Identified
    September 08, 2022 at 10:23 AM

    The error only affects user having "reels" media on their Instagram account. Deselecting the `media_insights` stream from the replication will solve the error while we are working on a fix.

  • Investigating
    September 08, 2022 at 7:05 AM

    Customers using Instagram source connector are impacted by the following error on sync: Message: Call was not successful Method: GET Path: https://graph.facebook.com/v11.0/17973371965736557/insights Params: {'metric': '["engagement","impressions","reach","saved","video_views"]'}

    ``` Status: 400 Response: { "error": { "message": "(#100) Incompatible metrics (engagement, impressions, videoviews) with reel media", "type": "OAuthException", "code": 100, "fbtraceid": "Ag9zXA1WCLta5VZ7pakZJIu" } } ```