Airbyte - Null Integers Becoming 0 – Incident details

Null Integers Becoming 0

Resolved
Degraded performance
Started 4 months agoLasted 4 days

Affected

Database Sources

Degraded performance from 8:20 PM to 9:44 PM

All Other Database Sources

Degraded performance from 8:20 PM to 9:44 PM

Snowflake Source

Degraded performance from 8:20 PM to 9:44 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. If you have noticed any null integers become 0 values in your destination, resetting the connection should correct any potential data discrepancies.

    Apologies for any inconvenience and thank you for your patience as we worked to resolve this issue. Please reach out to Airbyte Support if you have questions or concerns.

  • Identified
    Identified

    Some users are reporting that if there is a nullable integer column in the source, null values are becoming 0.

    We have rolled back to a previous version and are continuing to work on a permanent fix for this incident.