Airbyte - Source Linkedin - Array field as source-defined primary key issue with Destination BigQuery. – Incident details

Source Linkedin - Array field as source-defined primary key issue with Destination BigQuery.

Resolved
Operational
Started 3 months agoLasted 12 days

Affected

API Sources

Operational from 10:32 AM to 12:52 PM, Partial outage from 12:52 PM to 5:22 PM, Operational from 5:22 PM to 7:52 PM, Partial outage from 7:52 PM to 12:03 PM

LinkedIn Ads

Operational from 10:32 AM to 12:52 PM, Partial outage from 12:52 PM to 5:22 PM, Operational from 5:22 PM to 7:52 PM, Partial outage from 7:52 PM to 12:03 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. All impacted users should now be able to update source schema to use a healthy Primary Key and return syncs to a healthy state.

  • Identified
    Identified

    We are continuing to see issues while processing complex primary keys(array/JSON type) that are output by Linked In Ads for users syncing to destination BigQuery. We are continuing to work on a fix for this incident.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result. This fix is a breaking change and will require a reset on your connection. More information here.

  • Identified
    Identified

    There are issues with processing complex primary keys(array/JSON type) that are output by Linked In Ads for users syncing to destination BigQuery. We are continuing to work on a fix for this incident.

  • Investigating
    Investigating
    We are currently investigating this incident.