Airbyte - Source: Facebook Marketing - nonexisting fields error – Incident details

Source: Facebook Marketing - nonexisting fields error

Resolved
Operational
Started about 2 months agoLasted 4 days

Affected

API Sources

Major outage from 8:30 PM to 5:11 PM, Operational from 5:11 PM to 1:15 PM

Facebook Marketing Source

Major outage from 8:30 PM to 5:11 PM, Operational from 5:11 PM to 1:15 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    As a reminder, this fix is a breaking change. This requires an upgrade to the new 3.1.0 version of Facebook Marketing. Please follow the steps here to successfully update the connector.

  • Monitoring
    Monitoring

    The team has provided a fix which is a breaking change. This requires an upgrade to the new version 3.1.0 of Facebook Marketing. Please follow the steps here to successfully update the connector.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. Meta Appears to have silently modified the schema of the AdsInsights endpoint for conversion_lead_rate and cost_per_conversion_lead  causing the following error message:

    "error": {
            "message": "(#100) Tried accessing nonexisting field (cost_per_conversion_lead) on node type (AdsInsights)",
  • Investigating
    Investigating

    We are currently investigating this incident. Meta Appears to have silently modified the schema of the AdsInsights endpoint for conversion_lead_rate and cost_per_conversion_lead  causing the following error message:

    "error": {
            "message": "(#100) Tried accessing nonexisting field (cost_per_conversion_lead) on node type (AdsInsights)",