Completed
Enabling point-in-time recovery on our internal database

Status
Resolved after 30 minutes
Started
October 12, 2023 at 10:00 PM
Completed
October 12, 2023 at 10:30 PM
Affects
Data Sync
  • Completed
    October 12, 2023 at 10:30 PM
    Completed
    October 12, 2023 at 10:30 PM

    Maintenance has completed successfully

  • In progress
    October 12, 2023 at 10:00 PM
    In progress
    October 12, 2023 at 10:00 PM

    Maintenance is now in progress

  • Planned
    October 12, 2023 at 10:00 PM
    Planned
    October 12, 2023 at 10:00 PM

    Maintenance:
    Enable the point-in-time recovery option on the main Postgres database. This should be a zero-downtime operation but we noticed that connections were dropping while testing in the Staging Environment. Our backend systems do reconnect but there could be an impact on transactions that are in-flight. We estimate that the operation will take 20min to 30min, but the connection dropping only occurred during a smaller time frame of a couple of minutes in the beginning.

    Why does it matter:

    • Reduces data loss from hours to seconds in case of a database failure
    • Enables us to conduct database recovery exercises without downtime as required per SOC II and ISO 27001.