Airbyte - Shopify Stream Deprecation - `products_graph_ql` and `customer_saved_search` – Incident details

Shopify Stream Deprecation - `products_graph_ql` and `customer_saved_search`

Resolved
Degraded performance
Started 19 days agoLasted 23 minutes

Affected

API Sources

Degraded performance from 11:37 PM to 12:00 AM

Shopify

Degraded performance from 11:37 PM to 12:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    The Shopify API removed the endpoints powering the products_graph_ql and customer_saved_search earlier than expected. This has caused some connections with those streams active to fail. The newest version of the Airbyte Shopify Connector resolves the error. The products stream on the new version of the connector can be used in place of the deprecated products_graph_ql stream. More details can be found here: https://docs.airbyte.com/integrations/sources/shopify-migrations#upgrading-to-260