LinkedIn Ads experiencing partial outage

Billing Page Inaccessible

Resolved
Degraded performance
Started 8 months ago Lasted about 3 hours

Affected

WebApp
Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience as we worked to resolve this issue.

  • Identified
    Identified

    We have investigated and identified an issue related to the billing page. At this time our billing page is inaccessible. Our team is actively working on a fix. Thank you for your patience as we work to resolve this issue.