Airbyte - Source Shopify failing bulk operations due to third party change – Incident details

Source Shopify failing bulk operations due to third party change

Resolved
Partial outage 30 %
Started 18 days agoLasted about 6 hours

Affected

API Sources

Partial outage from 8:30 AM to 2:10 PM, Operational from 2:10 PM to 2:10 PM

Shopify Source

Partial outage from 8:30 AM to 2:10 PM, Operational from 2:10 PM to 2:10 PM

Third Party Component

Partial outage from 8:30 AM to 2:10 PM, Operational from 2:10 PM to 2:10 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Shopify has implemented a fix and are currently monitoring the result.

  • Identified
    Identified

    Syncs using the order_agreements stream in the Shopify source connector are failing with the error:

    The parent 'node' field for a nested connection must return a type that implements the 'Node' interface.

    This is caused by a change on Shopify's side to their Bulk Operations API validation. The stricter validation now rejects bulk queries where nested connections use types that don't implement the Node interface — the agreements connection falls into this category

    https://community.shopify.dev/t/admin-graphql-api-failure-when-fetching-sales-data-from-agreements-node/33344/10

  • Investigating
    Investigating
    We are currently investigating this incident.